Il sito per chi ama smanettare con Arduino, Raspberry Pi & Co.
I file ci sono ma n...
 

I file ci sono ma non si vedono  

   RSS

0

Ciao a tutti,
ho preparato un Raspberry pi come stazione torrent e server Plex, e funziona!
...ma evidentemente c'è un piccolo problema:
da terminale vedo i file presenti nella partizione montata, transmission e Plex usano la cartella senza problemi invece dal file manager la cartella torrent in cui è montata la partizione risulta vuota, come anche da filezilla quando accedo da remoto....
La partizione è montata così da fstab:

proc /proc proc defaults 0 0
PARTUUID=dc045e96-01 /boot vfat defaults 0 2
PARTUUID=dc045e96-02 / ext4 defaults,noatime 0 1
# a swapfile is not a swap partition, no line here
# use dphys-swapfile swap[on|off] for that
#/dev/sda1: UUID="d7937f87-1ba8-490b-ae76-013d9a568617" TYPE="ext4" PARTUUID="4edb02a5-01"
UUID=d7937f87-1ba8-490b-ae76-013d9a568617 /Desktop/torrent ext4 rw,defaults 0 0

...e questi sono i permessi:

ls -l /Desktop | grep torrent
drwxrwxrwx 7 pi pi 4096 set 18 15:35 torrent

Qualcuno ha un'idea del perchè?

Questa discussione è stata modificata 2 mesi fa da admin

JJForkber

6 Answers
0

ad occhio e croce sembra un problema di utenze, l'utente di torrent e quello di plex fanno parte del gruppo che ha accesso alla cartella di mount?

0

grazie per la risposta, ora cerco di capire come avere queste informazioni... googglo un po'

 

JJForkber

0

Ciao qui hai un link alla procedura completa per montare una memoria di massa usb: 

https://www.raspberrypi-spy.co.uk/2014/05/how-to-mount-a-usb-flash-disk-on-the-raspberry-pi/

C'è il file fstab, come editare la linea di mount ed inoltre nella procedura si vede come asssegnino all'inizio dei perrmessi alla cartella di mount, permessi non opzionali.

Prova a verificare se anche da te è tutto in ordine, ciao.

0

Di diverso dalla tua vedo già che specifichi due UID diversi per un disco solo, ciao

0

scusate sono un po' lento nell'interazione

#/dev/sda1: UUID="d7937f87-1ba8-490b-ae76-013d9a568617" TYPE="ext4" PARTUUID="4edb02a5-01"
UUID=d7937f87-1ba8-490b-ae76-013d9a568617 /Desktop/torrent ext4 rw,defaults 0 0

la prima è commentata...

comunque ho modificato fstab come da link e ovviamente da vnc non riesco più a connettermi col raspberry... la spia rossa e accesa e quella verde lampeggia, devo verificare che si avvii realmente. domani collego il monitor.

per ora grazie 

JJForkber

0

fstab e vnc sono indipendenti prova con ssh e vedi se il server è up e running..

ps

non vai meglio con rdp?

Questo post è stato modificato 1 mese fa da admin

Entra nel forum

Hai un nuovo progetto in mente ma hai dei dubbi su come realizzarlo? Vuoi condividere la tua conoscenza da maker con gli altri? Registrati nella nostra community e potrai chiedere fare la tua domanda o rispondere e condividere la tua conoscenza in internet.

Spread the love
  • 1
  •  
  •  
  •  
  •  
  •  
  •  
  •  
    1
    Share

Please Login or Registrazione